Performance update impacting successful crew deployments

Incident Report for CrewAI Enterprise - Status

Resolved

Incident resolved, after monitoring for a few hours, everything seem stable
Posted Jun 30, 2025 - 01:36 PDT

Monitoring

A Fix has been implemented, wea re monitoring the results
Posted Jun 29, 2025 - 23:07 PDT

Investigating

We are doing a regular performance improvement that ended up impacting new deployments and updates.
Existing deployed crews are running fine, we are looking into how to bring systems back to normal.
Posted Jun 29, 2025 - 22:04 PDT
This incident affected: CrewAI Enterprise (Enterprise Application).